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Az Android torténete

® Eredetileg az Android Inc. fejlesztése volt
® Google Inc. 2005-ben felvasarolta ©

® Mara az Android mogott tobb cég is (pl.: gyartok)
megtaldlhaté = Open Handset Alliance (OHA)

® ElsO elérhetd készulék: T-mobile G1 (HTC Dream), 2008
oktdberében jelent meg, Android 1.0 rendszer (Base)

® Azota:
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Forras:
http://gs.statcounter.com/ o0 BT o oo : : ;
#mobile os-ww-monthly- & \{;‘-’ & & \\rf’ £ & \\(;‘-’ \,oo’
201001-201302
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Android verziok Okostlelefon Api level

Api level @® 2.1 Ecair 7
* Folyamatosan novekvd szam I

* Fejlesztéskor hasznaljuk a minimalis @ 22 Froyo 8
Android verzio megjelolésére l

* API level alapjan eset valasztas. @ 2.3 Gingerbread 9,10
Pl.: adott funkcid csak bizonyos Tablet, 2.3.3=2.4

verzio (?ta ér,heté' el. 3 3.0 ’ Honeycomb 11
* Megkonnyiti a referenciaban N

vald tdjékozddast (filter): 31 @ 12
http://developer.android.com/ ‘

reference/packages.html 3.2 ‘ 13

Milyen verzidra @ 4.0 Ice Cream Sandwich 14

érdemes fejleszteni? I 4.0.3- 4.0.4 15
http://developer.android.com/about a.1 JeIIy Bean 16

/dashboards/index.html ,
%W -

®
P
@ 5.0 KeylimePie ?

Verzidk terjedésének sebessége

http://blog.tsabeeka.hu/2012/06/05/az-android-
verziok-elterjedesenek-sebessege/
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Amit jé tudni a platformrél

® Linux kernelre épil6 operacios rendszer

http://developer.android.com/guide/basics/what-is-android.html#os architecture

Linux 2.6.* kernelre épll, de az Android 4.0-t6l mar az uj 3.0.* kernelre.

® Dalvik VM virtualis gépen menedzselt Java kod futtatasa
(1= Sun JVM, és J2ME-vel sem kompatibilis)

® Open Source
® Parhuzamosan futhat tobb alkalmazas is (nincs megkotés)
® Google Play Store: egy instant alkalmazaspiac

® Ingyenes és fizetls szoftverek (30%-70%) ill. alkalmazason
bellli vasarlas lehetfsége (2.3 6ta)

® Offline alkalmazastelepités (unknow source) megengedett
® A mobilalkalmazas egyetlen fajlbol all (*.apk)

® Fejleszt6i kornyezet is ugyanugy fejlédik, mint maga a
rendszer (ADT)
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Programozas

® SDK - Java (Dalvik VM)

® NDK - C/C++ (Nativ kod, Java kodbol elérhet6 - JNI)
® ADK — Accessory Development Kit (3.1 6ta)

® Tovabbi kisérletek

® Script nyelvekkel (SL4A segitségével)
Pl.: Python, Perl, JavaScript, ...

http://code.google.com/p/android-scripting/

_ ; ; +1 érdekesség:
® C# (MonODrO|d keZdemenVEZES) Android app Windows-on
http://monodroid.net/

Fejlesztés

® Hivatalosan tamogatott IDE: Eclipse

® Az SDK rendelkezik emulatorral (kicsit lassu, idonként
problémas — szenzorok?)

® Futtathatunk kozvetlen telefonon (gyors, kényelmes — de
kell készulék)

® Bibliank: http://developer.android.com/
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Android alkalmazasokrol

® Az alkalmazasok egyenranguak
® Minden programot és képernydt egy stack-be rogzit

® Vissza (Back) gomb hatasara az el6z6 elemre valt at
(Gyakorlatilag, mint bongészében az el6zmények)

® Az alkalmazasok (hivatalosan) nem bezarhatoak, ezt maga a
rendszer végzi, ha szukség van ra. (Pl.: kevés memoria)

® Nem ablakok, hanem teljes képerny6t kitoltd Activity-k
® Egy alkalmazas tébb Activity-bdl allhat
® Minden Activity-nek sajat életciklusa van!

[ Start Activity 2 1 ( Start Activity 3 1 F Mavigate back j

Foreground activity

Activity 1 | Activity 2 | Activity 3 | Activity 2
R Activity 1 | Activity 2 I | Activity 1
[ ] Activity 3
Aﬂﬂ\flt}' 1 destroyed
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Activity életciklus modell

Célja:

* Varatlan események kezelése.
Pl.: bejovo hivds, akku mertilése
* Er6forrasok hatékony kezelése

A modellen abrazolt
metddusokat a rendszer
automatikusan meghivja,
amikor az szuikséges.

Forras:
http://developer.android.com/guide/t
opics/fundamentals.html#actlife

Ugyanez masképp:
http://www.google.hu/images?g=andr
oid+activity+lifecycle
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Fragments API

Tablet Handset

Selecting an item Selecting an item

{ updates Fragment B ? ( starts Activity B \l

Activity A containg Activity A contains Activity B contains
Fragment A and Fragment B Fragment A Fragment B

® Tervezési filozofia nagyobb képernybk kezelésére

® Gyakorlati szempontbdl megadhatjuk mely feltuletek
kertlhetnek egymas mellé. Lényegében Activity-n bellli
épitd elem.

® Bovebben:
http://developer.android.com/guide/topics/fundamentals/fragments.html
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Fejlesztoi kornyezet
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Fejlesztoi kornyezet telepitése

Mi kell hozza?

® JDK telepitse

® Eclipse IDE

® Android SDK

® ADT plugin (ADT = Android Development Tools)

Hogyan?

® Windows:
http://szyrt.hu/downloads/Docs/Android fejleszto kornyezet kialakitasa
Windowson.pdf

® Ubuntu 10.04 és felette:
http://szyrt.hu/downloads/Docs/Android fejleszto kornyezet kialakitasa
Ubuntu 10.04 en.pdf

® Eredeti leirds:
http://developer.android.com/sdk/installing.html
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Uj Android projekt

® File > New > Other... > Android > Android project
=TE ol

Select Build TEII'gEt | \ Applicatiun Info
Choose an SDK to karget Configure the new Android Project
7~ Euild Target o - - -
Application Mame: I My FirstAndroidProject
LT Nefme I '-.-'enu:h:u.r - I Platf. . I oo I Package Mame: Ihu.uniu:ul:uuu:la.nik
O android 2.1 Android Open Source Project 2.1 7
O Google &PTs Google Inc, 21 7 [¥ Create Activity: |MyFirstAndru:uidF'ru:uject.ﬁ.ctivity
O android 2.2 Android Open Source Project 2.2 G .
O Google &PIs @oogle Inc, 2.2 g Minimurn SDk.: I 15 j
O android 2.3.1  Android Open Source Project 2.3.1 a
O Gu:u:ugln_a APIs G-:u:ugln.a Inc. . 2.3.1 a I Create a Test Praject
O android 2.3.3  Android Open Source Project 2.3.3 10
O =oogle AP1s izoogle Inc, 23,3 10 Test Project Mame; |MyFirstAndruidPrDjectTest
E 222;?:' P.SF;;:*I; gzgrg?;dlgfen Saurce Project gg ii Test Application: | MyFirstandroidProject Tesk
O android 3.1 Android Open Source Project 3.1 1z Tiest Package: | b, uniobuda, nik. kest
O Google &PIs Google Inc, 31 12
O android 3.2 Android Open Source Projeck 3.2 13
O Google &PIs Google Inc, 3.2 13
O android 4.0 Android Open Source Prajeck 4.0 14
O =oogle aP1s coogle Inc, 4,0 14
([Glandroid 4.0.3  Android Open Source Project
O Google &PIs Google Inc, 4,03 15
Standard Android plakform 4.0.3

@:.l < Back I Mext = I Fimish Cancel |
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Ismerkedeés a feliilettel

& lava - MyFirstAndroidProject /src/hu/uniobuda/nik /MainActivity.ja¥a - Eclipse - |E’ |£|
File Edit Refactor Run Source Mavigate Search  Project  Window  Help Futtata's
= n = izl ] =
| % - uld lalBFdr-0-a-|ge-|®s - 7 | & v
J Pl 45 [E J - . - =
— Ty
[% Package Explarer 52 = EW )| Mainackivity java 3 = EI E: okl fQ Devw 22 . — O
-
= g package hu.uniohuds.nik: ;I =
E = MyFirstandroidProject - _ 5 e
B src #import android.app.lictivicy:[] i | G & O | - '°"|
=83 hu.uniobuda. ik eror | 0
m ManActivity.jave public class Mainhctivity extends Activity m I I I
' L4
EIEILE gen [Generated Java Fil F*% Called when the activity is first il
E|EE|l hu.uniobuda. nik, B BOverride
m R.java public volid onCreate (Bundle savedInsta
&= Android 2.1-updatel super.oncreate (savedlnstance3tate) Készulékek &
- q@ J— setContentWiew (. layout.main) ;
B85 res } Emulator, ill. futé
= & drawable-hepi ! Forraskodok . alkalmazasok
Z - "_'J icon, prng LI—I
El [E!:- drawable-ldpi
: - |"_':I icon. prig [L Proble @ Javad @) Dedlara | & Consal E Ernulat File Ex Resour LogiZat = 0
El IE!:- drawable-mdpi 0 items =
P |_.| icon. png
El E? lavout Description = | Resource | Fath | Location | T';.l:ue
S [X] main.=ml I Debug
- == values
----- 2| AndroidManifest, <l B)
----- default, properties

KT

.

T
::E,'Start| E8=| [

| ‘i'ritable | amarkt Inserk | 13: 2

|

Munkakonyvtar
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A munkakonyvtar szerkezete

src/ Az Activity Java fajljai és minden egyéb Java fajl.

gen/ ADT altal generalt R.java fajl helye. Segitségével érhetjlik
el Java kdédban az res/ konyvtarban taldlhaté tartalmakat.

assets/ Alapértelmezetten Ures konyvtar. RAW (nyers adat)
tartalmakat tarolhatunk itt.

res/ Kilonbozé forrasok, melyeket beépitenénk az
alkalmazasba.

res/drawable/ Képek és rajzok. Pl.: PNG, JPG, GIF, Ikonok, Drawable-t
leir6 XML-ek (selector, shape, ...)

res/layout/ Activity feltletét, layout-okat leird XML fajlok.

res/menu/ Men felépitését leiré XML-ek. Pl.: Options menii

res/values/ Kilonbozb értékek, szovegek, szamok, szinek, tombok

taroldasa XML formaban. Pl.: nyelvi fajlok
res/xml/ Tovabbi XML-ek, pl.: Beallitas fellletének leirdsa

AndroidManifest.xm|  Fontos informacidk, hasznalati jogok, min. SDK verzié,
Activity-k, Service-ok, Broadcast-ek nyilvantartasa, stb...
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Futtatas: Emulatoron

& Create new Android Yirtual Device (A¥D) ! x| Ul And rOId VIrtualls eszkoz
MName: l HTC-Hero h 74 4
ozzaadasa
Target: IAndroid 2.1-updatel - API Level 7 LI
D Card: Window > AVD Manager > New
& size: [1024 {mis |
" File: | P .
Beallithatjuk
S hat: . /7
= * Hardveres jellemz&ket
, * Android verziot
Skin:
% Built-in: HYGA v ’ ’ « »
L : | N Emulatorrél tudni érdemes:
esolution: X
* Lassucska szegény
Hardware: . , P "y
—_— (e — * New/Edit utén, elsd inditaskor
e = — mindig lassabb, mint egyébként
e e 1 * Emulator is egy virtualis gep
Bax Vi Spicotion heap Sxe L2 * Nem mindent tamogat: szenzorok,
Camera support ves
bluetooth, ...
™ Override the existing AYD with the same name e Emulatorira nyftalsa b|||enty(jzette|

Create AYD Cancel
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Futtatas

: Emulatoron (2)

o000

\ ~ /
% o A
A <

(= O Q)

1|2 03 4|5 |6 |7 |8 |9 [0
o w e [R 7 |v |ufrjo[p
A ls o[l [uls [k i [&
2z x c|v e lnm|. [&
2 0 ! 2 P
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Futtatas: Kozvetlenul telefonon

1. A "debuggable" jelz6 bedllitasa AndroidManifest.xml-ben!

2. Telefonon USB debugging engedélyezése!
Settings > Applications > Development
3.  USBdriver letoltése az ADB-nek (Android Debug Bridge):

B Window > Android SDK Manager > Available packages > Third party ...
n Vagy OEM Driverek:
http://developer.android.com/sdk/oem-usb.html

4. USB kabellel 6sszekotod
Az ADB telepitésénél meg kell adni a driver helyét.

5. Szlikség esetén az Eclipse és/vagy rendszer Ujrainditasa

® Ha sikerult, akkor Devices fiil alatt [athatdak a csatlakoztatott eszk6zok
® Devices ful el6hozasa:

EE Outline ['-!af§ Yiew Properties ] B.Dg\{i;es: 23\\ =
Window > Show Views > ¥ 60|22 Q| &~
Other.. > Android > Devices  fame

= ® HT9B3L900532 | Online 2.1-updatel
com.google.ar 4779 3601

® Eredeti leiras:
http://developer.android.com/guide/developing/device.html
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Debug - DDMS

® Dalvik Debug Monitor Server
Eclipse-ben: Window > Open Perspective > Other... > DDMS
Flggetlenl: [SDK path] / tools / ddms.bat

Lépései:
1. Breakpoint elhelyezése, mint
barmely ismert fejlesztbi

Debug mddba tessziik

o= outline | B Devices 53

ZEle@O| 3R S

kdrnyezetben.

Devices ful alatt a kivalasztott
késziiléken az adott alkalmazas
,debug” modba kapcsolasa.

A Innls s2lm wagy max ) Imogatls

{Breakpoint elhelyezve

ujjak szama = (byte)Math.min(ujjzk.length, &

Mame

------ & ujjak_szama= 2

El"

online
Ze459

HT9E3L900559
b, ponke, mobile . smarkciky

com,google, android, apps.up 28153

android. drawing

* A debug modban futtatott
alkalmazas lassu.
* De utdlag is atvalthatunk!
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Debug(2) - LogCat

® Készulék vagy emulator kivalasztasa a Devices fllon

® LogCat ful alatt listazodik minden ami a rendszerben torténik

T iy
12 Problems (@ Javadoc (@ Declaration (E Consale (@ Ernulator Contral ( File Explorer (@ LogCat &3 = O
Saved Filker ISearch for messages, Accepks lava regexes, Prefix with pid:, app:, kag: or bext Iverl:u:use j H Eﬂ 0 n
All messages Fi
L..| Time | P | Application | Tag | Text |
I OE-1g lE:33:3.. FEELE wpa suppl. .. CTEL-EVENT-STATE-CHAING.
w 0Z-12 12:33:3_. 119 WMifiMonitor Event [CTRL-EVENT-STAT!
W 02-12 12:-:33:3_. 1129 WMifidtate. .. Chanhgihg supplicant =t
I Oz-12 1z:33:3_. FZL1E wpa suppl... | WPA: Group rekeying col
e s I Oz-1g 1z:33:3.. FEE1E wpa suppl. .. CTEL-EVENT-STATE-CHAING.
Uj SZUrO v oz-1z 1z:33:3.. 1129 WifiMonitor  Event [WPA: Group reke
w 0Z-12 12:33:3_. 119 WMifiMonitor Event [CTRL-EVENT-STAT!
oo 02-12 12:-:33:3.. 11&9 WifiState... Changing supplicant sti_
1| | 3

Ajanlott filter hasznalata:

® Log.d("cimke", "Ez torténik:" + this.toString());
x|

7
® Ujszlré:
J * Logcat Message Filter Settings
Filker logcat messages by the source's tag, pid or minimum log level,
Ernpty Figlds will match all messages.

Filter Name: I

by Log Tag: |

by Log Message: I

by PID: |

by Application Mame: I

by Log Level: Iverbose 'I

?\ ancel 18
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